Cross-site Scripting in eZFind spellcheckGHSA-9cq2-pcgr-8h62
Fix: ezsystems/ezfind@51c17eaGHSA-9cq2-pcgr-8h62 is a security vulnerability in ezsystems/ezfind-ls. A fix is available for ezsystems/ezfind-ls — see the affected versions and patch details below.
Real-World Exposure
ezsystems/ezfind-ls🐘ezsystems/ezfind-ls🐘ezsystems/ezfind-lsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
This security advisory fixes a vulnerability in the legacy eZ Find extension, which can be used with the LegacyBridge in eZ Platform. It affects sites using the "Did you mean...?" spell check / search suggestion feature. This feature is vulnerable to Cross-site Scripting (XSS) injection (reflected XSS). The update adds the necessary escaping of injected code. If you're affected, we recommend that you install it as soon as possible.
If you have custom search templates, please make sure you update these as well. Ensure that "search_extras.spellcheck_collation" is followed by the "wash" operator, like this: {$search_extras.spellcheck_collation|wash}
To install, use Composer to update to one of the "Resolving versions" mentioned above, or apply this patch manually: https://github.com/ezsystems/ezfind/commit/51c17ea9b1231c20db8221f34d01c649060f1e91
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | ezsystems/ezfind-ls | ≥ 2017.12.0&&< 2017.12.0.1 | 2017.12.0.1composer require ezsystems/ezfind-ls:^2017.12.0.1 |
| 🐘Packagist | ezsystems/ezfind-ls | ≥ 5.4.0&&< 5.4.11.1 | 5.4.11.1composer require ezsystems/ezfind-ls:^5.4.11.1 |
| 🐘Packagist | ezsystems/ezfind-ls | ≥ 5.3.0&&< 5.3.6.1 | 5.3.6.1composer require ezsystems/ezfind-ls:^5.3.6.1 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ezsystems/ezfind-ls, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update ezsystems/ezfind-ls to 2017.12.0.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-9cq2-pcgr-8h62 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-9cq2-pcgr-8h62 in your dependencies?
Find it across Packagist, including transitive dependencies.