NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

snakeYAML before 1.31 vulnerable to Denial of Service due to Out-of-bounds WriteGHSA-98wm-3w3q-mw94

MEDIUM

GHSA-98wm-3w3q-mw94 is a medium-severity (CVSS 6.5) CWE-121 vulnerability in org.yaml:snakeyaml. A fix is available for org.yaml:snakeyaml — see the affected versions and patch details below.

Also known asCVE-2022-38751
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-98wm-3w3q-mw94.

EPSS Exploitation Probability

via FIRST.org ↗
2.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs81th percentile — riskier than 81% of all scored CVEsHighest risk
0.00%0.86%1.72%2.58%0.2%2.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.yaml:snakeyaml

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Using snakeYAML to parse untrusted YAML files may be vulnerable to Denial of Service attacks (DOS). If the parser is running on user supplied input, an attacker may supply content that causes the parser to crash by stackoverflow.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.yaml:snakeyamlall versions1.31org.yaml:snakeyaml:1.31

Affected Products

2 products · 2 configurations
OS
debian linuxdebian
1 version
10.0
Application
snakeyamlsnakeyaml_project
< 1.31
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.yaml:snakeyaml, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.yaml:snakeyaml to 1.31 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-98wm-3w3q-mw94 is resolved across your whole dependency graph.

  3. Workarounds

    Stop feeding it untrusted input: reject or quarantine files and payloads from unverified sources until you can upgrade, restrict accepted formats to the ones you actually need, and run the parsing or decoding step in a least-privileged sandbox or short-lived worker so a crash or corrupted read cannot reach the rest of the process.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate

Red Hat Build of Quarkus is not affected by this issue as it already includes the fixed version. Satellite component Candlepin does not directly use snakeyaml, so it is not affected. Regardless, an update with the latest, unaffected snakeyaml version will be provided at next release.

ProductFixed inAdvisory
Red Hat AMQ Broker 7snakeyamlRHSA-2022:8876
Red Hat build of Eclipse Vert.x 4.3.3snakeyamlRHSA-2022:6757
Red Hat Data Grid 8.4.0snakeyamlRHSA-2022:8524
Red Hat Satellite 6.13 for RHEL 8candlepin-0:4.2.13-1.el8satRHSA-2023:2097
Red Hat Single Sign-On 7snakeyamlRHSA-2023:1049
Red Hat Single Sign-On 7.6 for RHEL 7rh-sso7-keycloak-0:18.0.6-1.redhat_00001.1.el7ssoRHSA-2023:1043
Red Hat Single Sign-On 7.6 for RHEL 8rh-sso7-keycloak-0:18.0.6-1.redhat_00001.1.el8ssoRHSA-2023:1044
Red Hat Single Sign-On 7.6 for RHEL 9rh-sso7-keycloak-0:18.0.6-1.redhat_00001.1.el9ssoRHSA-2023:1045

Frequently Asked Questions

Using snakeYAML to parse untrusted YAML files may be vulnerable to Denial of Service attacks (DOS). If the parser is running on user supplied input, an attacker may supply content that causes the parser to crash by stackoverflow.
O3 Security · Impact-Aware SCA

Is GHSA-98wm-3w3q-mw94 in your dependencies?

Find it across Maven, including transitive dependencies.

snakeYAML before 1.31 vulnerable to Denial of Service…