fabric8 kubernetes-client vulnerableGHSA-98g7-rxmf-rrxm
MEDIUMFix: fabric8io/kubernetes-client@4451030GHSA-98g7-rxmf-rrxm is a medium-severity (CVSS 6.7) Deserialization of Untrusted Data vulnerability in io.fabric8:kubernetes-client. A fix is available for io.fabric8:kubernetes-client — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
io.fabric8:kubernetes-client☕io.fabric8:kubernetes-client☕io.fabric8:kubernetes-client☕io.fabric8:kubernetes-client☕io.fabric8:kubernetes-client☕io.fabric8:kubernetes-client☕io.fabric8:kubernetes-clientReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
A arbitrary code execution flaw was found in the Fabric 8 Kubernetes client affecting versions 5.0.0-beta-1 and above. Due to an improperly configured YAML parsing, this will allow a local and privileged attacker to supply malicious YAML.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | io.fabric8:kubernetes-client | ≥ 5.0.0-beta-1&&< 5.0.3 | 5.0.3io.fabric8:kubernetes-client:5.0.3 |
| ☕Maven | io.fabric8:kubernetes-client | ≥ 5.1.0&&< 5.1.2 | 5.1.2io.fabric8:kubernetes-client:5.1.2 |
| ☕Maven | io.fabric8:kubernetes-client | ≥ 5.2.0&&< 5.3.2 | 5.3.2io.fabric8:kubernetes-client:5.3.2 |
| ☕Maven | io.fabric8:kubernetes-client | ≥ 5.5.0&&< 5.7.4 | 5.7.4io.fabric8:kubernetes-client:5.7.4 |
| ☕Maven | io.fabric8:kubernetes-client | ≥ 5.8.0&&< 5.8.1 | 5.8.1io.fabric8:kubernetes-client:5.8.1 |
| ☕Maven | io.fabric8:kubernetes-client | ≥ 5.9.0&&< 5.10.2 | 5.10.2io.fabric8:kubernetes-client:5.10.2 |
Affected Products
a-mq streamsredhatbuild of quarkusredhatdescision managerredhatfabric8-kubernetesredhatfuseredhatintegration camel kredhatDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for io.fabric8:kubernetes-client, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update io.fabric8:kubernetes-client to 5.0.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-98g7-rxmf-rrxm is resolved across your whole dependency graph.
Workarounds
Do not deserialise data from untrusted sources: where the format allows it, restrict deserialisation to an explicit allowlist of expected types, and prefer a data-only format (JSON, Protobuf) over one that can reconstruct arbitrary objects until you can upgrade.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Red Hat CodeReady Studio 12 is not affected by this flaw because it does not ship a vulnerable version of kubernetes-client; the version that it ships does not use SnakeYAML.
| Product | Fixed in | Advisory |
|---|---|---|
| OCP-Tools-4.13-RHEL-8 | jenkins-2-plugins-0:4.13.1684911916-1.el8 | RHSA-2023:3299 |
| Red Hat AMQ Streams 1.6.7 | see advisory | RHSA-2022:0467 |
| Red Hat AMQ Streams 2.0.1 | kubernetes-client | RHSA-2022:0469 |
| Red Hat build of Quarkus 2.2.5 | kubernetes-client | RHSA-2022:0589 |
| Red Hat Fuse 7.11 | kubernetes-client | RHSA-2022:5532 |
| RHINT Camel-Q 2.2.1 | see advisory | RHSA-2022:1013 |
| Text-Only RHOAR | kubernetes-client | RHSA-2022:8761 |
Frequently Asked Questions
Is GHSA-98g7-rxmf-rrxm in your dependencies?
Find it across Maven, including transitive dependencies.