Quarkus CORS filter allows simple GET and POST requests with an invalid Origin to proceedGHSA-9895-g6x5-xwcp
HIGHGHSA-9895-g6x5-xwcp is a high-severity (CVSS 7.5) CWE-1026 vulnerability in io.quarkus:quarkus-vertx-http. A fix is available for io.quarkus:quarkus-vertx-http — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-9895-g6x5-xwcp.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
io.quarkus:quarkus-vertx-http☕io.quarkus:quarkus-vertx-httpReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Quarkus CORS filter allows simple GET and POST requests with invalid Origin to proceed. Simple GET or POST requests made with XMLHttpRequest are the ones which have no event listeners registered on the object returned by the XMLHttpRequest upload property and have no ReadableStream object used in the request.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | io.quarkus:quarkus-vertx-http | ≥ 2.14.0.CR1&&< 2.14.2.Final | 2.14.2.Finalio.quarkus:quarkus-vertx-http:2.14.2.Final |
| ☕Maven | io.quarkus:quarkus-vertx-http | all versions | 2.13.5.Finalio.quarkus:quarkus-vertx-http:2.13.5.Final |
Affected Products
quarkusquarkusDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for io.quarkus:quarkus-vertx-http, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update io.quarkus:quarkus-vertx-http to 2.14.2.Final or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-9895-g6x5-xwcp is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat build of Quarkus 2.13.5 | see advisory | RHSA-2022:9023 |
| Red Hat build of Quarkus Platform 2.7.6.SP3 | quarkus-vertx-http | RHSA-2022:8957 |
Frequently Asked Questions
Is GHSA-9895-g6x5-xwcp in your dependencies?
Find it across Maven, including transitive dependencies.