Elliptic's ECDSA missing check for whether leading bit of r and s is zeroGHSA-977x-g7h5-7qgw
MEDIUMFix: indutny/elliptic#317GHSA-977x-g7h5-7qgw is a medium-severity (CVSS 5.3) CWE-130 vulnerability in elliptic. A fix is available for elliptic — see the affected versions and patch details below.
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
Exploitation and automatability from CISA’s SSVC triage for GHSA-977x-g7h5-7qgw.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
ellipticnpmDescription
In the Elliptic package 6.5.6 for Node.js, ECDSA signature malleability occurs because there is a missing check for whether the leading bit of r and s is zero.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | elliptic | ≥ 2.0.0&&< 6.5.7 | 6.5.7npm install elliptic@6.5.7 |
Affected Products
ellipticindutnyDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for elliptic, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update elliptic to 6.5.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-977x-g7h5-7qgw is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for GHSA-977x-g7h5-7qgw (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| multicluster engine for Kubernetes 2.4 for RHEL 8 | multicluster-engine/addon-manager-rhel8:v2.4.6-12 | RHSA-2024:8533 |
| multicluster engine for Kubernetes 2.5 for RHEL 9 | multicluster-engine/console-mce-rhel9:v2.5.7-3 | RHSA-2024:6738 |
| multicluster engine for Kubernetes 2.6 for RHEL 8 | multicluster-engine/assisted-image-service-rhel8:v2.6.3-2 | RHSA-2024:7759 |
| Red Hat Advanced Cluster Management for Kubernetes 2.10 for RHEL 9 | rhacm2/console-rhel9:v2.10.6-3 | RHSA-2024:6779 |
| Red Hat Advanced Cluster Management for Kubernetes 2.11 for RHEL 9 | rhacm2/acm-cluster-permission-rhel9:v2.11.3-4 | RHSA-2024:7994 |
| Red Hat Advanced Cluster Management for Kubernetes 2.9 for RHEL 8 | rhacm2/acm-cluster-permission-rhel8:v2.9.5-9 | RHSA-2024:8546 |
| Red Hat OpenShift Service Mesh 2.4 for RHEL 8 | openshift-service-mesh/grafana-rhel8:2.4.10-3 | RHSA-2024:6209 |
| Red Hat OpenShift Service Mesh 2.5 for RHEL 8 | openshift-service-mesh/grafana-rhel8:2.5.4-3 | RHSA-2024:6210 |
Frequently Asked Questions
Is GHSA-977x-g7h5-7qgw in your dependencies?
Find it across npm, including transitive dependencies.