opensearch-ruby 2.x before 2.0.2 vulnerable to unsafe YAML deserializationGHSA-977c-63xq-cgw3
HIGHFix: opensearch-project/opensearch-ruby#77GHSA-977c-63xq-cgw3 is a high-severity (CVSS 8.8) Deserialization of Untrusted Data vulnerability in opensearch-ruby. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for opensearch-ruby — see the affected versions and patch details below.
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
- A successful exploit gives an attacker total control of the affected component, not partial access.
Exploitation and automatability from CISA’s SSVC triage for GHSA-977c-63xq-cgw3.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
opensearch-rubyReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.
Description
Impact
A YAML deserialization in opensearch-ruby 2.0.0 can lead to unsafe deserialization using YAML.load if the response is of type YAML.
Patches
The problem has been patched in opensearch-ruby gem version 2.0.2.
Workarounds
No viable workaround. Please upgrade to 2.0.2
References
https://github.com/opensearch-project/opensearch-ruby/pull/77 https://staaldraad.github.io/post/2021-01-09-universal-rce-ruby-yaml-load-updated/
For more information
If you have any questions or comments about this advisory:
- Open an issue in opensearch-ruby
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 💎RubyGems | opensearch-ruby | ≥ 2.0.0&&< 2.0.2 | 2.0.2bundle update opensearch-ruby --conservative |
Affected Products
opensearchamazonResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for opensearch-ruby, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update opensearch-ruby to 2.0.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-977c-63xq-cgw3 is resolved across your whole dependency graph.
Workarounds
Do not deserialise data from untrusted sources: where the format allows it, restrict deserialisation to an explicit allowlist of expected types, and prefer a data-only format (JSON, Protobuf) over one that can reconstruct arbitrary objects until you can upgrade.
Frequently Asked Questions
Is GHSA-977c-63xq-cgw3 in your dependencies?
Find it across RubyGems, including transitive dependencies.