NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

TYPO3 CMS Insecure DeserializationGHSA-96jg-pmc4-cx39

HIGH

GHSA-96jg-pmc4-cx39 is a high-severity (CVSS 7.5) remote code execution vulnerability in typo3/cms-core. A fix is available for typo3/cms-core — see the affected versions and patch details below.

Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Dec 5, 2024 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

2 pkgs affected
🐘typo3/cms-core🐘typo3/cms-core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

It has been discovered that the Form Framework (system extension form) is vulnerable to Insecure Deserialization when being used with the additional PHP PECL package yaml, which is capable of unserializing YAML contents to PHP objects. A valid backend user account as well as having PHP setting yaml.decode_php enabled is needed to exploit this vulnerability (which is the default value according to PHP documentation).

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagisttypo3/cms-core≥ 8.5.0&&< 8.7.178.7.17composer require typo3/cms-core:^8.7.17
🐘Packagisttypo3/cms-core≥ 9.0.0&&< 9.3.19.3.1composer require typo3/cms-core:^9.3.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/cms-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update typo3/cms-core to 8.7.17 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-96jg-pmc4-cx39 is resolved across your whole dependency graph.

  3. Workarounds

    Do not deserialise data from untrusted sources: where the format allows it, restrict deserialisation to an explicit allowlist of expected types, and prefer a data-only format (JSON, Protobuf) over one that can reconstruct arbitrary objects until you can upgrade.

Frequently Asked Questions

It has been discovered that the Form Framework (system extension `form`) is vulnerable to Insecure Deserialization when being used with the additional PHP PECL package `yaml`, which is capable of unserializing YAML contents to PHP objects. A valid backend user account as well as having PHP setting `yaml.decode_php` enabled is needed to exploit this vulnerability (which is the default value according to PHP documentation).
O3 Security · Impact-Aware SCA

Is GHSA-96jg-pmc4-cx39 in your dependencies?

Find it across Packagist, including transitive dependencies.

TYPO3 CMS Insecure Deserialization (High 7.5)