PHP-Textile has persistent XSS vulnerability in image link handlingGHSA-95m2-chm4-mq7m
HIGHFix: textile/php-textile@ab18ae9GHSA-95m2-chm4-mq7m is a high-severity (CVSS 7.3) vulnerability in netcarver/textile. A fix is available for netcarver/textile — see the affected versions and patch details below.
Real-World Exposure
netcarver/textileReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Details
Persistent XSS vulnerability in image link handling of PHP-Textile versions 4.1.2 and older, when running the parser in restricted mode. In restricted mode it is expected that the input would be sanitized, allowing user-input (such as user comments) to be parsed and handled safely by the PHP-Textile library.
In restricted mode, the version 4.1.2 of the library does not sanitize or validate user-controllable href input in image links, but allows any link protocol or JavaScriptt links to be used. The vulnerability allows an attacker to add malicious JavaScript code to the page which is then executed when an unexpecting user clicks the link.
In non-restricted mode, the library allows mixed HTML input, and any link protocol by design. In restricted mode, text links were already handled correctly and the vulnerability only affects image links.
Resolution
This issue was fixed in PHP-Textile version 4.1.3. Version 4.1.3 disallows use of JavaScript in image links when the parser is ran in restricted mode. Restricted mode can be enabled with Parser::setRestricted() method prior to calling the parse method. For more information, see Parsing unstructed input in the project's README.
PoC
The following Textile input:
!securing.pl(Click Tu)!:javascript:document.innerHTML='<script>alert(1);</script>'+document.cookie)
Would render as the following HTML even in restricted mode:
<p><a href="javascript:document.innerHTML='<script>alert(1);</script>'+document.cookie"><img alt="Click Tu" src="securing.pl" title="Click Tu"></a>)</p>
Impact
The attacker can perform any operation in the application with user’s privileges or remotely control user’s browser with automated tools.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | netcarver/textile | all versions | 4.1.3composer require netcarver/textile:^4.1.3 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for netcarver/textile, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update netcarver/textile to 4.1.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-95m2-chm4-mq7m is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-95m2-chm4-mq7m in your dependencies?
Find it across Packagist, including transitive dependencies.