NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍 PyPI
Not in CISA KEV

multicast in source builds from vulnerable setuptools dependencyGHSA-94v7-wxj6-r2q5

Fix: reactive-firewall/multicast@c5c7c7d

GHSA-94v7-wxj6-r2q5 is a security vulnerability in multicast. A fix is available for multicast — see the affected versions and patch details below.

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of May 28, 2025 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

1 pkg affected
🐍multicast

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Impact

  • Some source-builds may be impacted by a CWE-1395 (eg. vulnerable setuptools dependency).
    • Multicast prior to v2.0.9a3 on systems with minimal dependancies installed may use setuptools <78.1.1 and thus rely on a compromised dependency. In some cases there is a chance that source-builds would fail due to an exploit of the closely related CVE-2025-47273, or become arbitrarily modified.

Patches

  • Pre-release version v2.0.9a0 and later resolve the issue by bumping requirements to setuptools>=80.4
    • Pre-release version v2.0.9a3 and later are recommended for improved stability over v2.0.9a0

Workarounds

  • Further hardening in v2.0.9a4+ of the build process in CI builds allowing source builds to be verified via GH attestations.

References

Fixes

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPImulticastall versions2.0.9a0pip install --upgrade 'multicast==2.0.9a0'

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for multicast, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update multicast to 2.0.9a0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-94v7-wxj6-r2q5 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

### Impact * Some source-builds may be impacted by a CWE-1395 (eg. vulnerable `setuptools` dependency). * Multicast prior to v2.0.9a3 on systems with minimal dependancies installed may use `setuptools <78.1.1` and thus rely on a compromised dependency. In some cases there is a chance that source-builds would fail due to an exploit of the closely related CVE-2025-47273, or become arbitrarily modified. ### Patches * Pre-release version v2.0.9a0 and later resolve the issue by bumping requirements to `setuptools>=80.4` * Pre-release version v2.0.9a3 and later are recommended for improved
O3 Security · Impact-Aware SCA

Is GHSA-94v7-wxj6-r2q5 in your dependencies?

Find it across PyPI, including transitive dependencies.

GHSA-94v7-wxj6-r2q5: multicast — Fixed in 2.0.9a0