NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

Moodle XSS VulnerabilityGHSA-93gj-rg98-h7mm

MEDIUMFix: moodle/moodle@ac40d8b

GHSA-93gj-rg98-h7mm is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in moodle/moodle. A fix is available for moodle/moodle — see the affected versions and patch details below.

Also known asCVE-2017-2644
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 7, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs65th percentile — riskier than 65% of all scored CVEsHighest risk
0.00%0.52%1.04%1.55%0.3%1.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐘moodle/moodle🐘moodle/moodle

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

In Moodle 3.x, XSS can occur via evidence of prior learning.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmoodle/moodle≥ 3.2.0&&< 3.2.23.2.2composer require moodle/moodle:^3.2.2
🐘Packagistmoodle/moodle≥ 3.1.0&&< 3.1.53.1.5composer require moodle/moodle:^3.1.5

Affected Products

1 product · 16 configurations
Application
moodlemoodle
7 versions
3.1.03.1.13.1.23.1.33.1.43.2.03.2.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update moodle/moodle to 3.2.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-93gj-rg98-h7mm is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

In Moodle 3.x, XSS can occur via evidence of prior learning.
O3 Security · Impact-Aware SCA

Is GHSA-93gj-rg98-h7mm in your dependencies?

Find it across Packagist, including transitive dependencies.

Moodle XSS Vulnerability (Medium 6.1)