OpenClaw: Sandbox noVNC helper route exposed interactive browser session credentialsGHSA-92jp-89mq-4374
Fix: openclaw/openclaw#63882GHSA-92jp-89mq-4374 is a CWE-862 vulnerability in openclaw. A fix is available for openclaw — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-92jp-89mq-4374.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
openclawnpmDescription
Summary
Sandbox noVNC helper route exposed interactive browser session credentials.
Affected Packages / Versions
- Package:
openclaw - Ecosystem: npm
- Affected versions:
>= 2026.2.21 < 2026.4.10 - Patched versions:
>= 2026.4.10
Impact
The sandbox noVNC helper route could be reached without the intended bridge authentication, exposing an interactive browser session surface.
Technical Details
The fix gates the sandbox noVNC helper route behind bridge authentication.
Fix
The issue was fixed in #63882. The first stable tag containing the fix is v2026.4.10, and [email protected] includes the fix.
Fix Commit(s)
8dfbf3268bd224b7377d1ecca77a445100746085- PR: #63882
Release Process Note
Users should upgrade to openclaw 2026.4.10 or newer. The latest npm release, 2026.4.14, already includes the fix.
Credits
Thanks to @zsxsoft, with sponsorship from @KeenSecurityLab and @qclawer for reporting this issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | openclaw | ≥ 2026.2.21&&< 2026.4.10 | 2026.4.10npm install openclaw@2026.4.10 |
Affected Products
openclawopenclawDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for openclaw, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update openclaw to 2026.4.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-92jp-89mq-4374 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is GHSA-92jp-89mq-4374 in your dependencies?
Find it across npm, including transitive dependencies.