NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

Improper Certificate Validation in pyload-ngGHSA-8v53-23mx-hcf9

HIGHFix: pyload/pyload@a9098bd

GHSA-8v53-23mx-hcf9 is a high-severity (CVSS 7.4) CWE-295 vulnerability in pyload-ng. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for pyload-ng — see the affected versions and patch details below.

Also known asCVE-2023-0509PYSEC-2026-903
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • A successful exploit gives an attacker total control of the affected component, not partial access.

Exploitation and automatability from CISA’s SSVC triage for GHSA-8v53-23mx-hcf9.

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs45th percentile — riskier than 45% of all scored CVEsHighest risk
0.00%0.34%0.69%1.03%0.1%0.5%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍pyload-ng

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Improper Certificate Validation in GitHub repository pyload/pyload prior to 0.5.0b3.dev44.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIpyload-ngall versions0.5.0b3.dev44pip install --upgrade 'pyload-ng==0.5.0b3.dev44'

Affected Products

2 products · 2 configurations
Application
pyloadpyload
< 2023-01-25
range
Application
pyload-ngpyload-ng_project
< 0.5.0b3.dev44
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for pyload-ng, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update pyload-ng to 0.5.0b3.dev44 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-8v53-23mx-hcf9 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Improper Certificate Validation in GitHub repository pyload/pyload prior to 0.5.0b3.dev44.
O3 Security · Impact-Aware SCA

Is GHSA-8v53-23mx-hcf9 in your dependencies?

Find it across PyPI, including transitive dependencies.

Improper Certificate Validation in pyload-ng (High 7.4)