NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹 Go
Not in CISA KEV

Cosmos EVM VulnerabilityGHSA-8pfh-j44r-f654

Fix: cosmos/evm@79089fe

GHSA-8pfh-j44r-f654 is a security vulnerability in github.com/cosmos/evm. A fix is available for github.com/cosmos/evm — see the affected versions and patch details below.

Also known asGO-2025-4041
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 5, 2025 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

2 pkgs affected
🐹github.com/cosmos/evm🐹github.com/cosmos/evm

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Patches

Patched in versions v0.3.1, v0.4.2, and in the v0.5.0 release. More information will be disclosed at a later point to ensure chains have time to safely upgrade.

Workarounds

No workarounds for chains that make use of static or dynamic precompiles. Upgrading is strongly recommended.

Testing

Tests are introduced in every affected version.

Credits

Special thanks to @yihuang for the help on this issue.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/cosmos/evm≥ 0.3.0&&< 0.3.20.3.2go get github.com/cosmos/evm@v0.3.2
🐹Gogithub.com/cosmos/evm≥ 0.4.0&&< 0.4.20.4.2go get github.com/cosmos/evm@v0.4.2

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/cosmos/evm, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/cosmos/evm to 0.3.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-8pfh-j44r-f654 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

## Patches Patched in versions `v0.3.1`, `v0.4.2`, and in the `v0.5.0` release. More information will be disclosed at a later point to ensure chains have time to safely upgrade. ## Workarounds No workarounds for chains that make use of static or dynamic precompiles. Upgrading is strongly recommended. ## Testing Tests are introduced in every affected version. ## Credits Special thanks to @yihuang for the help on this issue.
O3 Security · Impact-Aware SCA

Is GHSA-8pfh-j44r-f654 in your dependencies?

Find it across Go, including transitive dependencies.

Cosmos EVM Vulnerability