Magento Broken authentication and session managememtGHSA-8mwx-wpp4-5xh4
CRITICALGHSA-8mwx-wpp4-5xh4 is a critical-severity (CVSS 9.8) CWE-613 vulnerability in magento/community-edition. A fix is available for magento/community-edition — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
magento/community-edition🐘magento/community-editionReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Insecure authentication and session management vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An unauthenticated user can append arbitrary session id that will not be invalidated by subsequent authentication.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | magento/community-edition | ≥ 2.2&&< 2.2.10 | 2.2.10composer require magento/community-edition:^2.2.10 |
| 🐘Packagist | magento/community-edition | ≥ 2.3&&< 2.3.2-p1 | 2.3.2-p1composer require magento/community-edition:^2.3.2-p1 |
Affected Products
magentomagentoDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for magento/community-edition, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update magento/community-edition to 2.2.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-8mwx-wpp4-5xh4 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is GHSA-8mwx-wpp4-5xh4 in your dependencies?
Find it across Packagist, including transitive dependencies.