NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

Cross-site Scripting via uploaded assetsGHSA-8jjh-j3c2-cjcv

HIGH

GHSA-8jjh-j3c2-cjcv is a high-severity (CVSS 7.5) Cross-site Scripting (XSS) vulnerability in statamic/cms. A fix is available for statamic/cms — see the affected versions and patch details below.

Also known asCVE-2023-48701
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs53th percentile — riskier than 53% of all scored CVEsHighest risk
0.20%0.62%1.04%1.45%1.0%0.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐘statamic/cms🐘statamic/cms

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Statamic CMS is a Laravel and Git powered content management system (CMS). Prior to versions 3.4.15 an 4.36.0, HTML files crafted to look like images may be uploaded regardless of mime validation. This is only applicable on front-end forms using the "Forms" feature containing an assets field, or within the control panel which requires authentication. This issue has been patched on 3.4.15 and 4.36.0.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagiststatamic/cmsall versions3.4.15composer require statamic/cms:^3.4.15
🐘Packagiststatamic/cms≥ 4.0.0&&< 4.36.04.36.0composer require statamic/cms:^4.36.0

Affected Products

1 product · 2 configurations
Application
statamicstatamic
≥ 4.0.0 && < 4.36.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for statamic/cms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update statamic/cms to 3.4.15 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-8jjh-j3c2-cjcv is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

### Impact HTML files crafted to look like images may be uploaded regardless of mime validation. This is only applicable on front-end forms using the "Forms" feature containing an assets field, or within the control panel which requires authentication. ### Patches It has been patched on 3.4.15 and 4.36.0.
O3 Security · Impact-Aware SCA

Is GHSA-8jjh-j3c2-cjcv in your dependencies?

Find it across Packagist, including transitive dependencies.

Cross-site Scripting via uploaded assets (High 7.5)