OpenClaw: /api/channels gateway-auth boundary bypass via path canonicalization mismatchGHSA-8j2w-6fmm-m587
MEDIUMGHSA-8j2w-6fmm-m587 is a medium-severity (CVSS 4.8) CWE-288 vulnerability in openclaw. A fix is available for openclaw — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-8j2w-6fmm-m587.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
openclawnpmDescription
Summary
Gateway auth for plugin channel endpoints can be bypassed when path canonicalization differs between the gateway guard and plugin handler routing.
Details
On affected versions, server-http only applies gateway auth when raw requestPath matches exactly:
/api/channels/api/channels/*
If a plugin handler canonicalizes path input (for example decodeURIComponent(pathname).toLowerCase()), requests like:
/API/channels/nostr/default/profile/api/channels%2Fnostr%2Fdefault%2Fprofilecan be interpreted as/api/channels/*by the plugin, while the gateway auth guard is skipped.
Impact
Authentication boundary bypass for plugin channel HTTP routes under canonicalization mismatch conditions. Unauthorized callers may access plugin channel APIs that are expected to require gateway auth.
CWE: CWE-288 (Authentication Bypass Using an Alternate Path or Channel)
CVSS: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N (Base 5.3, Moderate)
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | openclaw | all versions | 2026.2.26npm install openclaw@2026.2.26 |
Affected Products
openclawopenclawDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for openclaw, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update openclaw to 2026.2.26 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-8j2w-6fmm-m587 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is GHSA-8j2w-6fmm-m587 in your dependencies?
Find it across npm, including transitive dependencies.