NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹 Go
Not in CISA KEV

Ollama does not validate the format of the digest (sha256 with 64 hex digits)GHSA-8hqg-whrw-pv92

Fix: ollama/ollama#4175

GHSA-8hqg-whrw-pv92 is a Path Traversal vulnerability in github.com/ollama/ollama. 4 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for github.com/ollama/ollama — see the affected versions and patch details below.

Also known asCVE-2024-37032GO-2024-2901
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
4 known
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-8hqg-whrw-pv92.

EPSS Exploitation Probability

via FIRST.org ↗
89.6%probability of exploitation in next 30 days
Very High Risk0.00%
Lower risk than most CVEs100th percentile — riskier than 100% of all scored CVEsHighest risk
88.4%90.6%92.8%95.0%93.8%89.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
🐹github.com/ollama/ollama

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Ollama before 0.1.34 does not validate the format of the digest (sha256 with 64 hex digits) when getting the model path, and thus mishandles the TestGetBlobsPath test cases such as fewer than 64 hex digits, more than 64 hex digits, or an initial ../ substring.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/ollama/ollamaall versions0.1.34go get github.com/ollama/ollama@v0.1.34

Affected Products

1 product · 1 configurations
Application
ollamaollama
< 0.1.34
range
Exploits & PoCs
4

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/ollama/ollama, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/ollama/ollama to 0.1.34 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-8hqg-whrw-pv92 is resolved across your whole dependency graph.

  3. Workarounds

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

How to detect GHSA-8hqg-whrw-pv92

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id ghsa-8hqg-whrw-pv92 -u https://target
Template
Ollama - Remote Code Execution
Severity
critical
Impact
Attackers can exploit improper digest validation to achieve remote code execution on Ollama servers.
Remediation
Update Ollama to version 0.1.34 or later.

Template by ProjectDiscovery nuclei-templates (kaks3c), MIT licensed. View the full template. Scan only systems you are authorised to test.

Frequently Asked Questions

Ollama before 0.1.34 does not validate the format of the digest (sha256 with 64 hex digits) when getting the model path, and thus mishandles the TestGetBlobsPath test cases such as fewer than 64 hex digits, more than 64 hex digits, or an initial `../` substring.
O3 Security · Impact-Aware SCA

Is GHSA-8hqg-whrw-pv92 in your dependencies?

Find it across Go, including transitive dependencies.

Ollama does not validate the format of the digest (sha256…