NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🦀 crates.io
Not in CISA KEV

rPGP affected by crash in message handling for deeply nested messagesGHSA-8h58-w33p-wq3g

Fix: rpgp/rpgp#625

GHSA-8h58-w33p-wq3g is a remote code execution vulnerability in pgp. A fix is available for pgp — see the affected versions and patch details below.

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Feb 13, 2026 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

1 pkg affected
🦀pgp

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects crates.io packages — download data is not available via public APIs for these ecosystems.

Description

Summary

Previous rPGP versions could be caused to crash with a "stack overflow" when parsing messages that contain deeply nested message layers, such as messages with many signatures.

rPGP 0.19.0 resolves this issue with a more robust message handling implementation (via https://github.com/rpgp/rpgp/pull/625).

Impact

An attacker could cause applications to crash in rPGP's message parsing subsystem, when applications attempt to ingest messages.

Attribution

Discovered internally during rPGP development, using a fuzz test suite previously contributed by Christian Reitter.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🦀crates.iopgp≥ 0.16.0-alpha.0&&< 0.19.00.19.0cargo update -p pgp --precise 0.19.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for pgp, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update pgp to 0.19.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-8h58-w33p-wq3g is resolved across your whole dependency graph.

  3. Workarounds

    Stop feeding it untrusted input: reject or quarantine files and payloads from unverified sources until you can upgrade, restrict accepted formats to the ones you actually need, and run the parsing or decoding step in a least-privileged sandbox or short-lived worker so a crash or corrupted read cannot reach the rest of the process.

Frequently Asked Questions

### Summary Previous rPGP versions could be caused to crash with a "stack overflow" when parsing messages that contain deeply nested message layers, such as messages with many signatures. rPGP 0.19.0 resolves this issue with a more robust message handling implementation (via https://github.com/rpgp/rpgp/pull/625). ### Impact An attacker could cause applications to crash in rPGP's message parsing subsystem, when applications attempt to ingest messages. ### Attribution Discovered internally during rPGP development, using a fuzz test suite previously contributed by Christian Reitter.
O3 Security · Impact-Aware SCA

Is GHSA-8h58-w33p-wq3g in your dependencies?

Find it across crates.io, including transitive dependencies.

rPGP affected by crash in message handling for deeply…