NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

Microweber vulnerable to unrestricted malicious uploadsGHSA-8h43-xg5g-9cj7

HIGHFix: microweber/microweber@0d279ac

GHSA-8h43-xg5g-9cj7 is a high-severity (CVSS 7.2) Unrestricted File Upload vulnerability in microweber/microweber. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for microweber/microweber — see the affected versions and patch details below.

Also known asCVE-2022-4732
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.

Exploitation and automatability from CISA’s SSVC triage for GHSA-8h43-xg5g-9cj7.

EPSS Exploitation Probability

via FIRST.org ↗
38.2%probability of exploitation in next 30 days
Moderate Risk0.00%
Lower risk than most CVEs99th percentile — riskier than 99% of all scored CVEsHighest risk
0.00%16.5%32.9%49.4%1.1%38.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘microweber/microweber

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Unrestricted Upload of File with Dangerous Type in GitHub repository microweber/microweber prior to 1.3.2.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmicroweber/microweberall versions1.3.2composer require microweber/microweber:^1.3.2

Affected Products

1 product · 1 configurations
Application
microwebermicroweber
≤ 1.3.1
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for microweber/microweber, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update microweber/microweber to 1.3.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-8h43-xg5g-9cj7 is resolved across your whole dependency graph.

  3. Workarounds

    Treat uploaded files as untrusted until proven otherwise: validate the actual content type rather than the supplied extension, store uploads outside the web root on a volume mounted without execute permission, and rename them to server-generated identifiers so an attacker cannot choose the path a request will later resolve.

Frequently Asked Questions

Unrestricted Upload of File with Dangerous Type in GitHub repository microweber/microweber prior to 1.3.2.
O3 Security · Impact-Aware SCA

Is GHSA-8h43-xg5g-9cj7 in your dependencies?

Find it across Packagist, including transitive dependencies.

Microweber vulnerable to unrestricted malicious uploads