NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦 npm
Not in CISA KEV

next-intl has an open redirect vulnerabilityGHSA-8f24-v5vv-gm5j

Fix: amannn/next-intl#2304

GHSA-8f24-v5vv-gm5j is a Open Redirect vulnerability in next-intl. A fix is available for next-intl — see the affected versions and patch details below.

Also known asCVE-2026-40299
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-8f24-v5vv-gm5j.

EPSS Exploitation Probability

via FIRST.org ↗
0.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs28th percentile — riskier than 28% of all scored CVEsHighest risk
0.00%0.28%0.56%0.84%0.1%0.3%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

179other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
next-intlnpm
9.6Mdownloads / week

Description

Impact

Applications using the next-intl middleware with localePrefix: 'as-needed' could construct URLs where path handling and the WHATWG URL parser resolved a relative redirect target to another host (e.g. scheme-relative // or control characters stripped by the URL parser), so the middleware could redirect the browser off-site while the user still started from a trusted app URL.

Patches

The problem has been patched, please update to [email protected].

Credits

Many thanks to Joni Liljeblad from Oura for responsibly disclosing the vulnerability and for suggesting the fix.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmnext-intlall versions4.9.1npm install next-intl@4.9.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for next-intl, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update next-intl to 4.9.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-8f24-v5vv-gm5j is resolved across your whole dependency graph.

  3. Workarounds

    Stop reflecting attacker-controlled destinations: resolve every redirect target against an allowlist of paths or hosts you own, prefer a server-side key over a full URL in the request, and reject absolute URLs entirely where the flow only ever needs a relative one.

Frequently Asked Questions

### Impact Applications using the `next-intl` middleware with `localePrefix: 'as-needed'` could construct URLs where path handling and the WHATWG URL parser resolved a relative redirect target to another host (e.g. scheme-relative `//` or control characters stripped by the URL parser), so the middleware could redirect the browser off-site while the user still started from a trusted app URL. ### Patches The problem has been patched, please update to [`[email protected]`](https://github.com/amannn/next-intl/releases/tag/v4.9.1). ### Credits Many thanks to [Joni Liljeblad](https://github.com/j
O3 Security · Impact-Aware SCA

Is GHSA-8f24-v5vv-gm5j in your dependencies?

Find it across npm, including transitive dependencies.

GHSA-8f24-v5vv-gm5j: next-intl — Fixed in 4.9.1