NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI💎 RubyGems
Not in CISA KEV
HIGH severity

Missing Initialization of Resource in Apache ArrowGHSA-8cw2-jv5c-c825

HIGH

GHSA-8cw2-jv5c-c825 is a high-severity (CVSS 7.5) CWE-909 vulnerability in pyarrow. A fix is available for pyarrow — see the affected versions and patch details below.

Also known asCVE-2019-12408PYSEC-2019-195
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
3.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs88th percentile — riskier than 88% of all scored CVEsHighest risk
2.42%2.89%3.36%3.84%3.3%3.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐍pyarrow💎red-arrow

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI, RubyGems packages — download data is not available via public APIs for these ecosystems.

Description

It was discovered that the C++ implementation (which underlies the R, Python and Ruby implementations) of Apache Arrow 0.14.0 to 0.14.1 had a uninitialized memory bug when building arrays with null values in some cases. This can lead to uninitialized memory being unintentionally shared if Arrow Arrays are transmitted over the wire (for instance with Flight) or persisted in the streaming IPC and file formats.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIpyarrow≥ 0.14.0&&< 0.15.10.15.1pip install --upgrade 'pyarrow==0.15.1'
💎RubyGemsred-arrow≥ 0.14.0&&< 0.15.10.15.1bundle update red-arrow --conservative

Affected Products

1 product · 1 configurations
Application
arrowapache
≥ 0.14.0 && ≤ 0.14.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for pyarrow, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update pyarrow to 0.15.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-8cw2-jv5c-c825 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

It was discovered that the C++ implementation (which underlies the R, Python and Ruby implementations) of Apache Arrow 0.14.0 to 0.14.1 had a uninitialized memory bug when building arrays with null values in some cases. This can lead to uninitialized memory being unintentionally shared if Arrow Arrays are transmitted over the wire (for instance with Flight) or persisted in the streaming IPC and file formats.
O3 Security · Impact-Aware SCA

Is GHSA-8cw2-jv5c-c825 in your dependencies?

Find it across PyPI, RubyGems, including transitive dependencies.

Missing Initialization of Resource in Apache Arrow