OpenClaw has SSRF guard bypass via IPv6 transition over ISATAPGHSA-8cp7-rp8r-mg77
Fix: openclaw/openclaw@d51929eGHSA-8cp7-rp8r-mg77 is a security vulnerability in openclaw. A fix is available for openclaw — see the affected versions and patch details below.
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
openclawnpmDescription
Summary
OpenClaw's SSRF hostname/IP guard did not detect ISATAP embedded IPv4 addresses (...:5efe:w.x.y.z). A crafted URL containing an ISATAP IPv6 literal could embed a private IPv4 target (for example loopback) and bypass private-address filtering in URL-fetching paths.
Severity Assessment
Rated medium: the bug weakens SSRF protections in URL fetch flows, but impact depends on reaching a URL-fetching path with attacker-controlled input and is generally constrained to internal network access attempts.
Affected Packages / Versions
- Package:
openclaw(npm) - Affected:
>=2026.1.20 <=2026.2.17 - Latest published at patch time:
2026.2.17 - Patched release:
2026.2.19
Security Policy Context
Per SECURITY.md, OpenClaw's web/gateway surface is intended for local use by default, public internet exposure is out-of-scope, and prompt-injection reports are out-of-scope for bounty handling. This advisory tracks a core SSRF-guard bypass in fetch protections.
Impact
This can permit SSRF-style access attempts to internal/private network targets through URL ingestion/fetch paths that rely on shared hostname/IP blocking.
Fix
- Added RFC 5214 ISATAP embedded-IPv4 detection to the shared SSRF classifier.
- Centralized hostname/IP blocking through
isBlockedHostnameOrIpand routed relevant validators to that shared path. - Added regression tests for ISATAP private vs public embedded IPv4 handling.
Fix Commit(s)
d51929ecb52fe65e90bf36795f4247feb29eb8aa
OpenClaw thanks @zpbrent for reporting.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | openclaw | ≥ 2026.1.20&&< 2026.2.19 | 2026.2.19npm install openclaw@2026.2.19 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for openclaw, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update openclaw to 2026.2.19 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-8cp7-rp8r-mg77 is resolved across your whole dependency graph.
Workarounds
Restrict outbound requests from the affected component to an allowlist of hosts, block access to link-local and internal address ranges at the network layer, and require authentication on internal services so a forged request cannot reach them unauthenticated.
Frequently Asked Questions
Is GHSA-8cp7-rp8r-mg77 in your dependencies?
Find it across npm, including transitive dependencies.