Cross-Site Request Forgery in Spring FrameworkGHSA-8cmm-qj8g-fcp6
Fix: spring-projects/spring-framework@1a8629dGHSA-8cmm-qj8g-fcp6 is a Cross-Site Request Forgery (CSRF) vulnerability in org.springframework:spring-webmvc. EPSS puts its 30-day exploitation probability at 91.4% (100th percentile). A fix is available for org.springframework:spring-webmvc — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
org.springframework:spring-webmvc☕org.springframework:spring-webmvcReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
The Jaxb2RootElementHttpMessageConverter in Spring MVC in Spring Framework before 3.2.8 and 4.0.0 before 4.0.2 does not disable external entity resolution, which allows remote attackers to read arbitrary files, cause a denial of service, and conduct CSRF attacks via crafted XML, aka an XML External Entity (XXE) issue. NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-4152, CVE-2013-7315, and CVE-2013-6429.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.springframework:spring-webmvc | all versions | 3.2.8org.springframework:spring-webmvc:3.2.8 |
| ☕Maven | org.springframework:spring-webmvc | ≥ 4.0.0&&< 4.0.2 | 4.0.2org.springframework:spring-webmvc:4.0.2 |
Affected Products
spring frameworkspringsourcespring frameworkvmwareDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.springframework:spring-webmvc, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.springframework:spring-webmvc to 3.2.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-8cmm-qj8g-fcp6 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
The Red Hat Security Response Team has rated this issue as having Moderate security impact. OpenShift Enterprise 1 is currently in the Production 1 phase of its lifecycle, as such this issue is not currently planned to be addressed in future updates. For additional information, refer to the Satellite Life Cycle:…
Frequently Asked Questions
Is GHSA-8cmm-qj8g-fcp6 in your dependencies?
Find it across Maven, including transitive dependencies.