TYPO3 Cross-Site Scripting in Frontend User LoginGHSA-8c25-vj2w-p72j
MEDIUMGHSA-8c25-vj2w-p72j is a medium-severity (CVSS 6.1) vulnerability in typo3/cms-core. A fix is available for typo3/cms-core — see the affected versions and patch details below.
Real-World Exposure
typo3/cms-core🐘typo3/cms-core🐘typo3/cms-coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Failing to properly encode user input, login status display is vulnerable to cross-site scripting in the website frontend. A valid user account is needed in order to exploit this vulnerability - either a backend user or a frontend user having the possibility to modify their user profile.
Template patterns that are affected are
- ###FEUSER_[fieldName]### using system extension felogin
- <!--###USERNAME###--> for regular frontend rendering (pattern can be defined individually using TypoScript setting config.USERNAME_substToken)
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | typo3/cms-core | ≥ 8.0.0&&< 8.7.21 | 8.7.21composer require typo3/cms-core:^8.7.21 |
| 🐘Packagist | typo3/cms-core | ≥ 9.0.0&&< 9.5.2 | 9.5.2composer require typo3/cms-core:^9.5.2 |
| 🐘Packagist | typo3/cms-core | ≥ 7.1.0&&< 7.6.32 | 7.6.32composer require typo3/cms-core:^7.6.32 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/cms-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update typo3/cms-core to 8.7.21 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-8c25-vj2w-p72j is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-8c25-vj2w-p72j in your dependencies?
Find it across Packagist, including transitive dependencies.