go-grpc-compression has a zstd decompression bombing vulnerabilityGHSA-87m9-rv8p-rgmg
HIGHFix: mostynb/go-grpc-compression@629c44dGHSA-87m9-rv8p-rgmg is a high-severity (CVSS 7.5) vulnerability in github.com/mostynb/go-grpc-compression. A fix is available for github.com/mostynb/go-grpc-compression — see the affected versions and patch details below.
Real-World Exposure
github.com/mostynb/go-grpc-compressionReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Impact
A malicious user could cause a denial of service (DoS) when using a specially crafted gRPC request. The decompression mechanism for zstd did not respect the limits imposed by gRPC, allowing rapid memory usage increases.
Versions v1.1.4 through to v1.2.2 made use of the Decoder.DecodeAll function in github.com/klauspost/compress/zstd to decompress data provided by the peer. The vulnerability is exploitable only by attackers who can send gRPC payloads to users of github.com/mostynb/go-grpc-compression/zstd or github.com/mostynb/go-grpc-compression/nonclobbering/zstd.
Patches
Version v1.2.3 of github.com/mostynb/go-grpc-compression avoids the issue by not using the Decoder.DecodeAll function in github.com/klauspost/compress/zstd.
All users of github.com/mostynb/go-grpc-compression/zstd or github.com/mostynb/go-grpc-compression/nonclobbering/zstd in the affected versions should update to v1.2.3.
Workarounds
Other compression formats were not affected, users may consider switching from zstd to another format without upgrading to a newer release.
References
This issue was uncovered during a security audit performed by Miroslav Stampar of 7ASecurity, facilitated by OSTIF, for the OpenTelemetry project.
https://opentelemetry.io/blog/2024/cve-2024-36129 https://github.com/open-telemetry/opentelemetry-collector/security/advisories/GHSA-c74f-6mfw-mm4v
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/mostynb/go-grpc-compression | ≥ 1.1.4&&< 1.2.3 | 1.2.3go get github.com/mostynb/go-grpc-compression@v1.2.3 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/mostynb/go-grpc-compression, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/mostynb/go-grpc-compression to 1.2.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-87m9-rv8p-rgmg is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is GHSA-87m9-rv8p-rgmg in your dependencies?
Find it across Go, including transitive dependencies.