NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
HIGH severity

Insecure password handling vulnerability in StrapiGHSA-85vg-grr5-pw42

HIGHFix: strapi/strapi#12246

GHSA-85vg-grr5-pw42 is a high-severity (CVSS 7.5) CWE-522 vulnerability in strapi. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for strapi — see the affected versions and patch details below.

Also known asCVE-2021-46440
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
1 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs87th percentile — riskier than 87% of all scored CVEsHighest risk
2.29%2.72%3.15%3.59%3.1%2.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, a proxy for how much of the ecosystem is exposed.

strapinpm
11Kdownloads / week
@strapi/strapinpm
284Kdownloads / week

Description

Storing passwords in a recoverable format in the DOCUMENTATION plugin component of Strapi before 3.6.9 and 4.x before 4.1.5 allows an attacker to access a victim's HTTP request, get the victim's cookie, perform a base64 decode on the victim's cookie, and obtain a cleartext password, leading to getting API documentation for further API attacks.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
📦npmstrapiall versions3.6.9npm install strapi@3.6.9
📦npm@strapi/strapi≥ 4.0.0&&< 4.1.54.1.5npm install @strapi/strapi@4.1.5

Affected Products

1 product · 2 configurations
Application
strapistrapi
≥ 4.0.0 && < 4.1.5
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for strapi, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update strapi to 3.6.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-85vg-grr5-pw42 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Storing passwords in a recoverable format in the DOCUMENTATION plugin component of Strapi before 3.6.9 and 4.x before 4.1.5 allows an attacker to access a victim's HTTP request. From this, the attacker can get the victim's cookie, base64 decode it, and obtain a cleartext password, leading to getting API documentation for further API attacks.
O3 Security · Impact-Aware SCA

Is GHSA-85vg-grr5-pw42 in your dependencies?

Find it across npm, including transitive dependencies.

Insecure password handling vulnerability in Strapi