React Router: Potential CSRF via PUT/PATCH/DELETE document requestsGHSA-84g9-w2xq-vcv6
LOWGHSA-84g9-w2xq-vcv6 is a low-severity (CVSS 3.1) Cross-Site Request Forgery (CSRF) vulnerability in react-router. A fix is available for react-router — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-84g9-w2xq-vcv6.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
react-routernpm@remix-run/server-runtimenpmDescription
Certain CSRF checks in React Router v7 Framework Mode were insufficient and run on POST requests, but were bypassed on PUT/PATCH/DELETE requests. This is a low severity vulnerability because modern browser protections (CORS preflight, SameSite cookies) already block the cross-origin attack vectors that this missing CSRF check would otherwise gate.
[!NOTE] This does not impact your React Router application if you are using Declarative Mode (
<BrowserRouter>) or Data Mode (createBrowserRouter/<RouterProvider>).
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | react-router | ≥ 7.12.0&&< 7.15.1 | 7.15.1npm install react-router@7.15.1 |
| 📦npm | @remix-run/server-runtime | ≥ 2.17.3&&< 2.17.5 | 2.17.5npm install @remix-run/server-runtime@2.17.5 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for react-router, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update react-router to 7.15.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-84g9-w2xq-vcv6 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This is a Low impact vulnerability. Insufficient Cross-Site Request Forgery (CSRF) checks in React Router's framework mode could allow an attacker to bypass protections on PUT, PATCH, and DELETE requests. However, modern browser security features like CORS preflight and SameSite cookies significantly reduce the…
Red Hat products that ship react-router are affected by this CSRF bypass in Framework Mode on PUT, PATCH, and DELETE requests. However, modern browser protections — CORS preflight checks and SameSite cookie defaults — significantly limit the practical exploitability of this flaw. No specific workaround is required. Updating to react-router 7.15.1 or later, when available in product updates, will fully resolve this issue.Source: Red Hat security advisory for GHSA-84g9-w2xq-vcv6 (CC BY 4.0)
Frequently Asked Questions
Is GHSA-84g9-w2xq-vcv6 in your dependencies?
Find it across npm, including transitive dependencies.