@nfid/embed has compromised private key due to @dfinity/auth-client producing insecure session keysGHSA-84c3-j8r2-mcm8
CRITICALGHSA-84c3-j8r2-mcm8 is a critical-severity (CVSS 9.1) vulnerability in @nfid/embed. A fix is available for @nfid/embed — see the affected versions and patch details below.
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, a proxy for how much of the ecosystem is exposed.
@nfid/embednpmDescription
Problem
User sessions in the @nfid/embed SDK with Ed25519 keys are vulnerable due to a compromised private key 535yc-uxytb-gfk7h-tny7p-vjkoe-i4krp-3qmcl-uqfgr-cpgej-yqtjq-rqe. This exposes users to potential loss of funds on ledgers and unauthorized access to canisters they control.
Solution
Using version >1.0.1 of @dfinity/auth-client and @dfinity/identity packages, or @nfid/embed >0.10.1-alpha.6 includes patched versions of the issue.
User sessions will be automatically fixed when they re-authenticate.
Why this happened
The DFINITY auth client library provides a function, Ed25519KeyIdentity.generate, for generating an Ed25519 key pair. This function includes an optional parameter to supply a 32-byte seed value, which will be utilized as the secret key. In cases where no seed value is provided, the library is expected to generate the secret key using secure randomness. However, a recent update of DFINITY libraries has compromised this assurance by employing an insecure seed for key pair generation.
References
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | @nfid/embed | ≥ 0.10.0&&< 0.10.1-alpha.6 | 0.10.1-alpha.6npm install @nfid/embed@0.10.1-alpha.6 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @nfid/embed, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update @nfid/embed to 0.10.1-alpha.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-84c3-j8r2-mcm8 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-84c3-j8r2-mcm8 in your dependencies?
Find it across npm, including transitive dependencies.