Apache Ignite: Possible RCE when deserializing incoming messages by the server nodeGHSA-8355-xj3p-hv6q
CRITICALFix: apache/ignite@f1d3579GHSA-8355-xj3p-hv6q is a critical-severity (CVSS 9) Deserialization of Untrusted Data vulnerability in org.apache.ignite:ignite-core. A fix is available for org.apache.ignite:ignite-core — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-8355-xj3p-hv6q.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.ignite:ignite-coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
In Apache Ignite versions from 2.6.0 and before 2.17.0, configured Class Serialization Filters are ignored for some Ignite endpoints. The vulnerability could be exploited if an attacker manually crafts an Ignite message containing a vulnerable object whose class is present in the Ignite server classpath and sends it to Ignite server endpoints. Deserialization of such a message by the Ignite server may result in the execution of arbitrary code on the Apache Ignite server side.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.ignite:ignite-core | ≥ 2.6.0&&< 2.17.0 | 2.17.0org.apache.ignite:ignite-core:2.17.0 |
Affected Products
igniteapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.ignite:ignite-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.ignite:ignite-core to 2.17.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-8355-xj3p-hv6q is resolved across your whole dependency graph.
Workarounds
Do not deserialise data from untrusted sources: where the format allows it, restrict deserialisation to an explicit allowlist of expected types, and prefer a data-only format (JSON, Protobuf) over one that can reconstruct arbitrary objects until you can upgrade.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
No Red Hat products are affected by this vulnerability. This vulnerability marked as Important severity rather than Critical because, while it allows remote code execution (RCE), it requires specific conditions to be met for successful exploitation. An attacker must craft a malicious Ignite message containing a…
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for GHSA-8355-xj3p-hv6q (CC BY 4.0)
Frequently Asked Questions
Is GHSA-8355-xj3p-hv6q in your dependencies?
Find it across Maven, including transitive dependencies.