NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
💎
💎 RubyGems
Not in CISA KEV
CRITICAL severity

geokit-rails Command Injection vulnerabilityGHSA-7xvc-v44j-46fh

CRITICALFix: geokit/geokit-rails@7ffc581

GHSA-7xvc-v44j-46fh is a critical-severity (CVSS 9.8) OS Command Injection vulnerability in geokit-rails. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for geokit-rails — see the affected versions and patch details below.

Also known asCVE-2023-26153
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
2 known
Exploitation data as of Nov 7, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.

Exploitation and automatability from CISA’s SSVC triage for GHSA-7xvc-v44j-46fh.

EPSS Exploitation Probability

via FIRST.org ↗
3.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs90th percentile — riskier than 90% of all scored CVEsHighest risk
0.00%1.64%3.28%4.92%0.3%3.8%Jun 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
💎geokit-rails

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.

Description

Versions of the package geokit-rails before 2.5.0 are vulnerable to Command Injection due to unsafe deserialisation of YAML within the 'geo_location' cookie. This issue can be exploited remotely via a malicious cookie value.

Note:

An attacker can use this vulnerability to execute commands on the host system.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
💎RubyGemsgeokit-railsall versions2.5.0bundle update geokit-rails --conservative

Affected Products

1 product · 1 configurations
Application
geokit-railsgeokit
< 2.5.0
range
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for geokit-rails, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update geokit-rails to 2.5.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-7xvc-v44j-46fh is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

Versions of the package geokit-rails before 2.5.0 are vulnerable to Command Injection due to unsafe deserialisation of YAML within the 'geo_location' cookie. This issue can be exploited remotely via a malicious cookie value. **Note:** An attacker can use this vulnerability to execute commands on the host system.
O3 Security · Impact-Aware SCA

Is GHSA-7xvc-v44j-46fh in your dependencies?

Find it across RubyGems, including transitive dependencies.

geokit-rails Command Injection vulnerability (Critical 9.8)