Cross site scripting (XSS) in JupyterHub via Self-XSS leveraged by Cookie TossingGHSA-7r3h-4ph8-w38g
HIGHFix: jupyterhub/jupyterhub@e2798a0GHSA-7r3h-4ph8-w38g is a high-severity (CVSS 8.1) Cross-site Scripting (XSS) vulnerability in jupyterhub. A fix is available for jupyterhub — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-7r3h-4ph8-w38g.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
jupyterhubReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Impact
Affected configurations:
- Single-origin JupyterHub deployments
- JupyterHub deployments with user-controlled applications running on subdomains or peer subdomains of either the Hub or a single-user server.
By tricking a user into visiting a malicious subdomain, the attacker can achieve an XSS directly affecting the former's session. More precisely, in the context of JupyterHub, this XSS could achieve the following:
- Full access to JupyterHub API and user's single-user server, e.g.
- Create and exfiltrate an API Token
- Exfiltrate all files hosted on the user's single-user server: notebooks, images, etc.
- Install malicious extensions. They can be used as a backdoor to silently regain access to victim's session anytime.
Patches
To prevent cookie-tossing:
- Upgrade to JupyterHub 4.1 (both hub and user environment)
- enable per-user domains via
c.JupyterHub.subdomain_host = "https://mydomain.example.org" - set
c.JupyterHub.cookie_host_prefix_enabled = Trueto enable domain-locked cookies
or, if available (applies to earlier JupyterHub versions):
- deploy jupyterhub on its own domain, not shared with any other services
- enable per-user domains via
c.JupyterHub.subdomain_host = "https://mydomain.example.org"
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | jupyterhub | all versions | 4.1.0pip install --upgrade 'jupyterhub==4.1.0' |
Affected Products
jupyterhubjupyterDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for jupyterhub, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update jupyterhub to 4.1.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-7r3h-4ph8-w38g is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-7r3h-4ph8-w38g in your dependencies?
Find it across PyPI, including transitive dependencies.