NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

langchain SQL Injection vulnerabilityGHSA-7q94-qpjr-xpgm

HIGHFix: hwchase17/langchain#6051

GHSA-7q94-qpjr-xpgm is a high-severity (CVSS 7.5) SQL Injection vulnerability in langchain. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for langchain — see the affected versions and patch details below.

Also known asCVE-2023-36189PYSEC-2023-110
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-7q94-qpjr-xpgm.

EPSS Exploitation Probability

via FIRST.org ↗
1.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs69th percentile — riskier than 69% of all scored CVEsHighest risk
0.00%0.58%1.17%1.75%0.2%1.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍langchain

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

SQL injection vulnerability in langchain before v0.0.247 allows a remote attacker to obtain sensitive information via the SQLDatabaseChain component.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIlangchainall versions0.0.247pip install --upgrade 'langchain==0.0.247'

Affected Products

1 product · 1 configurations
Application
langchainlangchain
1 version
0.0.64
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for langchain, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update langchain to 0.0.247 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-7q94-qpjr-xpgm is resolved across your whole dependency graph.

  3. Workarounds

    Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.

Frequently Asked Questions

SQL injection vulnerability in langchain allows a remote attacker to obtain sensitive information via the SQLDatabaseChain component.
O3 Security · Impact-Aware SCA

Is GHSA-7q94-qpjr-xpgm in your dependencies?

Find it across PyPI, including transitive dependencies.

langchain SQL Injection vulnerability (High 7.5)