NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍 PyPI
Not in CISA KEV

Server crash if running Python 3.10 w/ Sanic 20.12GHSA-7p79-6x2v-5h88

GHSA-7p79-6x2v-5h88 is a security vulnerability in sanic. A fix is available for sanic — see the affected versions and patch details below.

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Dec 5, 2024 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

1 pkg affected
🐍sanic

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

!!! ONLY APPLIES TO VERSIONS PRIOR TO Sanic v20.12 WHEN USING Python 3.10 !!!

Sanic v20.12 officially supports Python versions 3.6, 3.7, 3.8, and 3.9. However, if you accidentally run it with version 3.10 (which is not supported by Sanic 20.12), your server is prone to crashing on an incoming web request.

Impact

Anyone running Sanic server between 0.1.7 and 20.12 using Python 3.10.

Patches

Sanic v20.12.6

Workarounds

Use a supported version of Python (v3.6 - v3.9)

References

In asyncio, the explicit passing of a loop argument has been deprecated and will be removed in version 3.10 for the following: ... asyncio.Event

Python 3.8 Release Notes

For more information

If you have any questions or comments about this advisory:

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIsanic≥ 0.1.7&&< 20.12.620.12.6pip install --upgrade 'sanic==20.12.6'

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for sanic, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update sanic to 20.12.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-7p79-6x2v-5h88 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

**!!! ONLY APPLIES TO VERSIONS PRIOR TO Sanic v20.12 WHEN USING Python 3.10 !!!** Sanic v20.12 officially supports Python versions 3.6, 3.7, 3.8, and 3.9. However, if you accidentally run it with version 3.10 (**which is not supported by Sanic 20.12**), your server is prone to crashing on an incoming web request. ### Impact Anyone running Sanic server between 0.1.7 and 20.12 **using Python 3.10**. ### Patches [Sanic v20.12.6](https://github.com/sanic-org/sanic/releases/tag/v20.12.6) ### Workarounds Use a supported version of Python (v3.6 - v3.9) ### References > In [asyncio](https://docs.
O3 Security · Impact-Aware SCA

Is GHSA-7p79-6x2v-5h88 in your dependencies?

Find it across PyPI, including transitive dependencies.

Server crash if running Python 3.10 w/ Sanic 20.12