ASAR Integrity bypass via filetype confusion in electronGHSA-7m48-wc93-9g85
MEDIUMFix: electron/electron#39788GHSA-7m48-wc93-9g85 is a medium-severity (CVSS 6.1) CWE-345 vulnerability in electron. A fix is available for electron — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
electronnpmDescription
Impact
This only impacts apps that have the embeddedAsarIntegrityValidation and onlyLoadAppFromAsar fuses enabled. Apps without these fuses enabled are not impacted. This issue is specific to macOS as these fuses are only currently supported on macOS.
Specifically this issue can only be exploited if your app is launched from a filesystem the attacker has write access too. i.e. the ability to edit files inside the resources folder in your app installation on Windows which these fuses are supposed to protect against.
Workarounds
There are no app side workarounds, you must update to a patched version of Electron.
Fixed Versions
27.0.0-alpha.726.2.125.8.124.8.322.3.24
For more information
If you have any questions or comments about this advisory, email us at [email protected]
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | electron | all versions | 22.3.24npm install electron@22.3.24 |
| 📦npm | electron | ≥ 24.0.0-alpha.1&&< 24.8.3 | 24.8.3npm install electron@24.8.3 |
| 📦npm | electron | ≥ 25.0.0-alpha.1&&< 25.8.1 | 25.8.1npm install electron@25.8.1 |
| 📦npm | electron | ≥ 26.0.0-alpha.1&&< 26.2.1 | 26.2.1npm install electron@26.2.1 |
| 📦npm | electron | ≥ 27.0.0-alpha.1&&< 27.0.0-alpha.7 | 27.0.0-alpha.7npm install electron@27.0.0-alpha.7 |
| 📦npm | electron | ≥ 23.0.0-alpha.1 | No fix |
Affected Products
electronelectronjsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for electron, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update electron to 22.3.24 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-7m48-wc93-9g85 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-7m48-wc93-9g85 in your dependencies?
Find it across npm, including transitive dependencies.