NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
HIGH severity

msgpackr's conversion of property names to strings can trigger infinite recursionGHSA-7hpj-7hhx-2fgx

HIGHFix: kriszyp/msgpackr@18f44f8

GHSA-7hpj-7hhx-2fgx is a high-severity (CVSS 8.6) CWE-674 vulnerability in msgpackr. A fix is available for msgpackr — see the affected versions and patch details below.

Also known asCVE-2023-52079
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-7hpj-7hhx-2fgx.

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs53th percentile — riskier than 53% of all scored CVEsHighest risk
0.00%0.39%0.79%1.19%0.5%0.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

556other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
msgpackrnpm
64.3Mdownloads / week

Description

msgpackr is a fast MessagePack NodeJS/JavaScript implementation. Prior to 1.10.1, when decoding user supplied MessagePack messages, users can trigger stuck threads by crafting messages that keep the decoder stuck in a loop. The fix is available in v1.10.1.
Exploits seem to require structured cloning, replacing the 0x70 extension with your own (that throws an error or does something other than recursive referencing) should mitigate the issue.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmmsgpackrall versions1.10.1npm install msgpackr@1.10.1

Affected Products

1 product · 1 configurations
Application
msgpackrkriszyp
< 1.10.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for msgpackr, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update msgpackr to 1.10.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-7hpj-7hhx-2fgx is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate

Red Hat rates this as a moderate impact vulnerability since it demands cloning a structure, which leads to high complexity.

Workaround published by Red Hat
No mitigation is currently found for this CVE.
Source: Red Hat security advisory for GHSA-7hpj-7hhx-2fgx (CC BY 4.0)

Frequently Asked Questions

### Impact When decoding user supplied MessagePack messages, users can trigger stuck threads by crafting messages that keep the decoder stuck in a loop. ### Patches The fix is available in v1.10.1 ### Workarounds Exploits seem to require structured cloning, replacing the 0x70 extension with your own (that throws an error or does something other than recursive referencing) should mitigate the issue. ### References
O3 Security · Impact-Aware SCA

Is GHSA-7hpj-7hhx-2fgx in your dependencies?

Find it across npm, including transitive dependencies.

GHSA-7hpj-7hhx-2fgx: msgpackr — Fixed in 1.10.1