NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
CRITICAL severity

Authentication bypass in Apache ShiroGHSA-7cj4-gj8m-m2f7

CRITICALFix: apache/shiro@dc194fc

GHSA-7cj4-gj8m-m2f7 is a critical-severity (CVSS 9.8) Improper Authentication vulnerability in org.apache.shiro:shiro-spring. A fix is available for org.apache.shiro:shiro-spring — see the affected versions and patch details below.

Also known asCVE-2020-17510
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
8.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs95th percentile — riskier than 95% of all scored CVEsHighest risk
0.00%3.79%7.58%11.4%1.8%8.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.apache.shiro:shiro-spring

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Apache Shiro before 1.7.0, when using Apache Shiro with Spring, a specially crafted HTTP request may cause an authentication bypass.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.shiro:shiro-springall versions1.7.0org.apache.shiro:shiro-spring:1.7.0

Affected Products

2 products · 2 configurations
Application
shiroapache
< 1.7.0
range
OS
debian linuxdebian
1 version
9.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.shiro:shiro-spring, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.shiro:shiro-spring to 1.7.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-7cj4-gj8m-m2f7 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant

Whilst the OpenDaylight version that is included in Red Hat OpenStack Platform includes the affected code, the vulnerable function is not used and therefore not exploitable.

ProductFixed inAdvisory
Red Hat Fuse 7.9shiro-coreRHSA-2021:3140

Frequently Asked Questions

Apache Shiro before 1.7.0, when using Apache Shiro with Spring, a specially crafted HTTP request may cause an authentication bypass.
O3 Security · Impact-Aware SCA

Is GHSA-7cj4-gj8m-m2f7 in your dependencies?

Find it across Maven, including transitive dependencies.

Authentication bypass in Apache Shiro (Critical 9.8)