NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦 npm
Not in CISA KEV

Malware in pre-build binaries of bignumGHSA-7cgc-fjv4-52x6

Fix: justmoon/node-bignum@57e48c3

GHSA-7cgc-fjv4-52x6 is a security vulnerability in bignum. A fix is available for bignum — see the affected versions and patch details below.

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of May 24, 2023 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

177other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
bignumnpm
5Kdownloads / week

Description

Impact

bignum releases from v0.12.2 to v0.13.0 (inclusive) used node-pre-gyp to optionally download pre-built binary versions of the addon. These binaries were published on a now-expired S3 bucket which has since been claimed by a malicious third party which is now serving binaries containing malware that exfiltrates data from the user's computer.

Patches

v0.13.1 does not use node-pre-gyp and does not have support for downloading pre-built binaries in any form, avoiding the risk of malicious downloads.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmbignum≥ 0.12.2&&< 0.13.10.13.1npm install bignum@0.13.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for bignum, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update bignum to 0.13.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-7cgc-fjv4-52x6 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

### Impact bignum releases from v0.12.2 to v0.13.0 (inclusive) used node-pre-gyp to optionally download pre-built binary versions of the addon. These binaries were published on a now-expired S3 bucket which has since been claimed by a malicious third party which is now serving binaries containing malware that exfiltrates data from the user's computer. ### Patches v0.13.1 does not use node-pre-gyp and does not have support for downloading pre-built binaries in any form, avoiding the risk of malicious downloads.
O3 Security · Impact-Aware SCA

Is GHSA-7cgc-fjv4-52x6 in your dependencies?

Find it across npm, including transitive dependencies.

Malware in pre-build binaries of bignum