NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
CRITICAL severity

Raneto v0.17.0 employs weak password complexity requirementsGHSA-7942-2fx8-qhpf

CRITICALFix: ryanlelek/Raneto#370

GHSA-7942-2fx8-qhpf is a critical-severity (CVSS 9.8) CWE-521 vulnerability in raneto. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for raneto — see the affected versions and patch details below.

Also known asCVE-2022-35143
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs77th percentile — riskier than 77% of all scored CVEsHighest risk
0.05%0.77%1.49%2.21%0.6%1.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

0other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
ranetonpm
203downloads / week

Description

Raneto v0.17.0 employs weak password complexity requirements, allowing attackers to crack user passwords via brute-force attacks. Version 0.17.1 contains security mitigations for this and other vulnerabilities.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmranetoall versions0.17.1npm install raneto@0.17.1

Affected Products

1 product · 1 configurations
Application
ranetoraneto_project
< 0.17.1
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for raneto, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update raneto to 0.17.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-7942-2fx8-qhpf is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Raneto v0.17.0 employs weak password complexity requirements, allowing attackers to crack user passwords via brute-force attacks. Version 0.17.1 contains security mitigations for this and other vulnerabilities.
O3 Security · Impact-Aware SCA

Is GHSA-7942-2fx8-qhpf in your dependencies?

Find it across npm, including transitive dependencies.

Raneto v0.17.0 employs weak password complexity…