NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

Laravel Encrypter Component Potential Decryption Failure Leading to Unintended BehaviorGHSA-7852-w36x-6mf6

Fix: laravel/framework@28e53f2

GHSA-7852-w36x-6mf6 is a security vulnerability in laravel/framework. A fix is available for laravel/framework — see the affected versions and patch details below.

Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 29, 2024 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

2 pkgs affected
🐘laravel/framework🐘laravel/framework

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

The Laravel Encrypter component is susceptible to a vulnerability that may result in decryption failure, leading to an unexpected return of false. Exploiting this issue requires the attacker to manipulate the encrypted payload before decryption. When combined with weak type comparisons in the application's code, such as the example below:

<?php

$decyptedValue = decrypt($secret);

if ($decryptedValue == '') {
    // Code is run even though decrypted value is false...
}

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistlaravel/frameworkall versions5.5.40composer require laravel/framework:^5.5.40
🐘Packagistlaravel/framework≥ 5.6.0&&< 5.6.155.6.15composer require laravel/framework:^5.6.15

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for laravel/framework, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update laravel/framework to 5.5.40 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-7852-w36x-6mf6 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

The Laravel Encrypter component is susceptible to a vulnerability that may result in decryption failure, leading to an unexpected return of `false`. Exploiting this issue requires the attacker to manipulate the encrypted payload before decryption. When combined with weak type comparisons in the application's code, such as the example below: ``` <?php $decyptedValue = decrypt($secret); if ($decryptedValue == '') { // Code is run even though decrypted value is false... } ```
O3 Security · Impact-Aware SCA

Is GHSA-7852-w36x-6mf6 in your dependencies?

Find it across Packagist, including transitive dependencies.

Laravel Encrypter Component Potential Decryption Failure…