NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🦀
🦀 crates.io
Not in CISA KEV
MEDIUM severity

zerovec-derive incorrectly uses `#[repr(packed)]`GHSA-74r5-g7vc-j2v2

MEDIUMFix: rustsec/advisory-db#2007

GHSA-74r5-g7vc-j2v2 is a medium-severity (CVSS 6.2) vulnerability in zerovec-derive. A fix is available for zerovec-derive — see the affected versions and patch details below.

Also known asRUSTSEC-2024-0346
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Sep 10, 2026 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

2 pkgs affected
🦀zerovec-derive🦀zerovec-derive

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects crates.io packages — download data is not available via public APIs for these ecosystems.

Description

The affected versions make unsafe memory accesses under the assumption that #[repr(packed)] has a guaranteed field order.

The Rust specification does not guarantee this, and https://github.com/rust-lang/rust/pull/125360 (1.80.0-beta) starts reordering fields of #[repr(packed)] structs, leading to illegal memory accesses.

The patched versions 0.9.7 and 0.10.3 use #[repr(C, packed)], which guarantees field order.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🦀crates.iozerovec-derive≥ 0.10.0&&< 0.10.30.10.3cargo update -p zerovec-derive --precise 0.10.3
🦀crates.iozerovec-deriveall versions0.9.7cargo update -p zerovec-derive --precise 0.9.7

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for zerovec-derive, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update zerovec-derive to 0.10.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-74r5-g7vc-j2v2 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

The affected versions make unsafe memory accesses under the assumption that `#[repr(packed)]` has a guaranteed field order. The Rust specification does not guarantee this, and https://github.com/rust-lang/rust/pull/125360 (1.80.0-beta) starts reordering fields of `#[repr(packed)]` structs, leading to illegal memory accesses. The patched versions `0.9.7` and `0.10.3` use `#[repr(C, packed)]`, which guarantees field order.
O3 Security · Impact-Aware SCA

Is GHSA-74r5-g7vc-j2v2 in your dependencies?

Find it across crates.io, including transitive dependencies.

GHSA-74r5-g7vc-j2v2: zerovec-derive — Fixed in 0.10.3