NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

AWS CLI: cli_history database does not restrict file permissions on Unix systemsGHSA-747p-wmpv-9c78

MEDIUM

GHSA-747p-wmpv-9c78 is a medium-severity (CVSS 5.9) vulnerability in awscli. A fix is available for awscli — see the affected versions and patch details below.

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Sep 10, 2026 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

1 pkg affected
🐍awscli

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Summary AWS CLI is a command line tool for interacting with AWS services. When the cli_history feature is enabled, the history database file is created with default permissions, potentially allowing other local users on a multi-user system to read the file.

Impact When cli_history is enabled, AWS CLI stores command history including command parameters and API request/response data in a local SQLite database. On multi-user Unix systems, the default file permissions may allow other local users to read this file, potentially exposing sensitive information. This issue only affects users who have explicitly enabled cli_history, which is disabled by default.

Impacted versions: 1.13.0 - 1.44.37 (v1), 2.0.0 - 2.33.20 (v2)

Patches This issue has been addressed in the latest versions 2.33.21 and 1.44.38 of AWS CLI. We recommend upgrading to the latest version and ensuring any forked or derivative code is patched to incorporate the new fixes.

Workarounds Users can manually set restrictive permissions on the history database file. Alternatively, disable cli_history by removing cli_history = enabled from the AWS config file.

Resources If there are any questions or comments about this advisory, contact AWS Security via the vulnerability reporting page or directly via email to [email protected]. Please do not create a public GitHub issue.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIawscli≥ 1.13.0&&< 1.44.381.44.38pip install --upgrade 'awscli==1.44.38'

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for awscli, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update awscli to 1.44.38 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-747p-wmpv-9c78 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

**Summary** AWS CLI is a command line tool for interacting with AWS services. When the cli_history feature is enabled, the history database file is created with default permissions, potentially allowing other local users on a multi-user system to read the file. **Impact** When cli_history is enabled, AWS CLI stores command history including command parameters and API request/response data in a local SQLite database. On multi-user Unix systems, the default file permissions may allow other local users to read this file, potentially exposing sensitive information. This issue only affects users w
O3 Security · Impact-Aware SCA

Is GHSA-747p-wmpv-9c78 in your dependencies?

Find it across PyPI, including transitive dependencies.

AWS CLI: cli_history database does not restrict file…