Parse Server has a protected fields bypass via logical query operatorsGHSA-72hp-qff8-4pvv
GHSA-72hp-qff8-4pvv is a CWE-284 vulnerability in parse-server. A fix is available for parse-server — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-72hp-qff8-4pvv.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
parse-servernpmDescription
Impact
The validation for protected fields only checks top-level query keys. By wrapping a query constraint on a protected field inside a logical operator, the check is bypassed entirely. This allows any authenticated user to query on protected fields to extract field values.
All Parse Server deployments have default protected fields and are vulnerable.
Patches
The fix adds recursive validation of sub-queries with logical operators, consistent with the existing recursive validation patterns.
Workarounds
Use a beforeFind trigger on affected classes to manually inspect the query for protected field references in logical operator sub-queries and reject the request.
References
- GitHub security advisory: https://github.com/parse-community/parse-server/security/advisories/GHSA-72hp-qff8-4pvv
- Fix Parse Server 9: https://github.com/parse-community/parse-server/releases/tag/9.5.2-alpha.6
- Fix Parse Server 8: https://github.com/parse-community/parse-server/releases/tag/8.6.19
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | parse-server | ≥ 9.0.0&&< 9.5.2-alpha.6 | 9.5.2-alpha.6npm install parse-server@9.5.2-alpha.6 |
| 📦npm | parse-server | all versions | 8.6.19npm install parse-server@8.6.19 |
Affected Products
parse-serverparseplatformDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for parse-server, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update parse-server to 9.5.2-alpha.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-72hp-qff8-4pvv is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is GHSA-72hp-qff8-4pvv in your dependencies?
Find it across npm, including transitive dependencies.