skilo add follows symbolic links, allowing arbitrary local file disclosure from a malicious skill sourceGHSA-6xx4-9wp6-65p7
MEDIUMFix: manuelmauro/skilo#11GHSA-6xx4-9wp6-65p7 is a medium-severity (CVSS 6.5) vulnerability in skilo. A fix is available for skilo — see the affected versions and patch details below.
Real-World Exposure
skiloReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects crates.io packages — download data is not available via public APIs for these ecosystems.
Description
Impact
skilo add installs a skill by recursively copying the skill directory into the
target skills directory. The copy routine (copy_dir_all) classified each entry
with std::fs::DirEntry::file_type() — which does not follow symlinks — and
then copied non-directory entries with std::fs::copy(), which does
dereference symlinks.
As a result, a skill containing a symbolic link such as
reference.txt -> /home/<user>/.ssh/id_rsa was copied as a regular file whose
contents are the link's target. A malicious skill source — for example a git
repository installed via skilo add github.com/<attacker>/<skills>, or a local
path — could read arbitrary files readable by the user running skilo add (SSH
keys, cloud credentials, .env files, etc.) and place their contents inside the
installed skill directory, where the user or their agent may later read, share,
or sync them.
This is arbitrary local file disclosure (CWE-59 / CWE-61, symlink following) triggered by installing an untrusted skills source.
Patches
Fixed in 0.11.1. copy_dir_all now rejects symbolic-link entries at any
recursion depth (failing closed with a dedicated error) instead of dereferencing
them.
Workarounds
- Only install skills from sources you trust.
- Inspect a skill source for symbolic links before running
skilo add.
Affected versions
Introduced together with the skilo add command in 0.5.0 and present through
0.11.0. Releases before 0.5.0 do not include the add command.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🦀crates.io | skilo | ≥ 0.5.0&&< 0.11.1 | 0.11.1cargo update -p skilo --precise 0.11.1 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for skilo, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update skilo to 0.11.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-6xx4-9wp6-65p7 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-6xx4-9wp6-65p7 in your dependencies?
Find it across crates.io, including transitive dependencies.