NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

Laravel Encrypter Failure to decryption vulnerabilityGHSA-6wjw-qf87-fv5v

Fix: illuminate/encryption@51667a5

GHSA-6wjw-qf87-fv5v is a security vulnerability in illuminate/encryption. A fix is available for illuminate/encryption — see the affected versions and patch details below.

Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 29, 2024 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

2 pkgs affected
🐘illuminate/encryption🐘illuminate/encryption

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

A potential exploit of the Laravel Encrypter component that may cause the Encrypter to fail on decryption and unexpectedly return false.

To exploit this, the attacker must be able to modify the encrypted payload before it is decrypted. Depending on the code within your application, this could lead to unexpected behavior when combined with weak type comparisons, for example:

<?php

$decyptedValue = decrypt($secret);

if ($decryptedValue == '') {
    // Code is run even though decrypted value is false...
}

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistilluminate/encryption≥ 5.5.0&&< 5.5.405.5.40composer require illuminate/encryption:^5.5.40
🐘Packagistilluminate/encryption≥ 5.6.0&&< 5.6.155.6.15composer require illuminate/encryption:^5.6.15

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for illuminate/encryption, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update illuminate/encryption to 5.5.40 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-6wjw-qf87-fv5v is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

A potential exploit of the Laravel Encrypter component that may cause the Encrypter to fail on decryption and unexpectedly return false. To exploit this, the attacker must be able to modify the encrypted payload before it is decrypted. Depending on the code within your application, this could lead to unexpected behavior when combined with weak type comparisons, for example: ```php <?php $decyptedValue = decrypt($secret); if ($decryptedValue == '') { // Code is run even though decrypted value is false... } ```
O3 Security · Impact-Aware SCA

Is GHSA-6wjw-qf87-fv5v in your dependencies?

Find it across Packagist, including transitive dependencies.

Laravel Encrypter Failure to decryption vulnerability