NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

Magento 2 Community Edition RCE VulnerabilityGHSA-6vc8-3xf2-qrxx

MEDIUM

GHSA-6vc8-3xf2-qrxx is a medium-severity (CVSS 6.6) CWE-362 vulnerability in magento/community-edition. A fix is available for magento/community-edition — see the affected versions and patch details below.

Also known asCVE-2019-8232
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs58th percentile — riskier than 58% of all scored CVEsHighest risk
0.00%0.45%0.90%1.35%0.1%0.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐘magento/community-edition🐘magento/community-edition

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

In Magento prior to 1.9.4.3, Magento prior to 1.14.4.3, Magento 2.2 prior to 2.2.10, and Magento 2.3 prior to 2.3.3 or 2.3.2-p1, an authenticated user with administrative privileges for the import feature can execute arbitrary code through a race condition that allows webserver configuration file modification.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmagento/community-edition≥ 2.2.0&&< 2.2.102.2.10composer require magento/community-edition:^2.2.10
🐘Packagistmagento/community-edition≥ 2.3.0&&< 2.3.2-p12.3.2-p1composer require magento/community-edition:^2.3.2-p1

Affected Products

1 product · 8 configurations
Application
magentomagento
≥ 2.3.0 && < 2.3.2
1 version
2.3.2

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for magento/community-edition, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update magento/community-edition to 2.2.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-6vc8-3xf2-qrxx is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

In Magento prior to 1.9.4.3, Magento prior to 1.14.4.3, Magento 2.2 prior to 2.2.10, and Magento 2.3 prior to 2.3.3 or 2.3.2-p1, an authenticated user with administrative privileges for the import feature can execute arbitrary code through a race condition that allows webserver configuration file modification.
O3 Security · Impact-Aware SCA

Is GHSA-6vc8-3xf2-qrxx in your dependencies?

Find it across Packagist, including transitive dependencies.

Magento 2 Community Edition RCE Vulnerability