NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

phpMyFAQ vulnerable to Cross-site ScriptingGHSA-6rj8-9cm9-6gff

HIGHFix: thorsten/phpmyfaq@37123ed

GHSA-6rj8-9cm9-6gff is a high-severity (CVSS 8.4) Cross-site Scripting (XSS) vulnerability in thorsten/phpmyfaq. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for thorsten/phpmyfaq — see the affected versions and patch details below.

Also known asCVE-2022-3608
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
1 known
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • A successful exploit gives an attacker total control of the affected component, not partial access.

Exploitation and automatability from CISA’s SSVC triage for GHSA-6rj8-9cm9-6gff.

EPSS Exploitation Probability

via FIRST.org ↗
1.2%probability of exploitation in next 30 days
Lower Risk+0.03%
Lower risk than most CVEs68th percentile — riskier than 68% of all scored CVEsHighest risk
0.01%0.57%1.12%1.68%0.5%1.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐘thorsten/phpmyfaq🐘phpmyfaq/phpmyfaq

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

phpMyFAQ versions 3.1.7 and prior are vulnerable to stored cross-site scripting (XSS). A patch is available on the main branch of the repository and anticipated to be part of version 3.2.0-alpha.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistthorsten/phpmyfaqall versions3.2.0-alphacomposer require thorsten/phpmyfaq:^3.2.0-alpha
🐘Packagistphpmyfaq/phpmyfaqall versions3.2.0-alphacomposer require phpmyfaq/phpmyfaq:^3.2.0-alpha

Affected Products

1 product · 1 configurations
Application
phpmyfaqphpmyfaq
≤ 3.1.7
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for thorsten/phpmyfaq, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update thorsten/phpmyfaq to 3.2.0-alpha or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-6rj8-9cm9-6gff is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

phpMyFAQ versions 3.1.7 and prior are vulnerable to stored cross-site scripting (XSS). A patch is available on the `main` branch of the repository and anticipated to be part of version 3.2.0-alpha.
O3 Security · Impact-Aware SCA

Is GHSA-6rj8-9cm9-6gff in your dependencies?

Find it across Packagist, including transitive dependencies.

phpMyFAQ vulnerable to Cross-site Scripting (High 8.4)