GHSA-6qv6-q77g-7qm6 is a critical-severity (CVSS 9.8) Deserialization of Untrusted Data vulnerability in nvflare. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for nvflare — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
nvflareReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Impact
NVFLARE contains a vulnerability where deserialization of Untrusted Data due to Pickle usage may allow an unprivileged network attacker to cause Remote Code Execution, Denial Of Service, and Impact to both Confidentiality and Integrity.
All versions before 2.1.4 are affected.
CVSS Score = 9.8
AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Patches
The patch is included in nvflare==2.1.4 This new version uses MessagePack instead of Pickle to do serialization and deserialization.
Some object serializations supported by Pickle are not supported by MessagePack. We have provided out of box support for some built-in NVFLARE objects. For object serializations unsupported by MessagePack, the user will need to convert the objects to numpy or bytes before sending over to remote machines. The list of supported object types are listed in https://github.com/NVIDIA/NVFlare/blob/2.1/nvflare/fuel/utils/fobs/README.rst
Workarounds
No workarounds available.
Additional information
Issue Found by: Oliver Sellwood (Nintorac) and Elias Hohl
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | nvflare | all versions | 2.1.4pip install --upgrade 'nvflare==2.1.4' |
Affected Products
nvflarenvidiaResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
NVFLARE < 2.1.4 - Unsafe Deserialization due to Pickle
by Elias Hohl · Mar 25, 2023
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for nvflare, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update nvflare to 2.1.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-6qv6-q77g-7qm6 is resolved across your whole dependency graph.
Workarounds
Do not deserialise data from untrusted sources: where the format allows it, restrict deserialisation to an explicit allowlist of expected types, and prefer a data-only format (JSON, Protobuf) over one that can reconstruct arbitrary objects until you can upgrade.
Frequently Asked Questions
Is GHSA-6qv6-q77g-7qm6 in your dependencies?
Find it across PyPI, including transitive dependencies.