github-slug-action vulnerable to arbitrary code executionGHSA-6q4m-7476-932w
HIGHFix: rlespinasse/github-slug-action@102b1a0GHSA-6q4m-7476-932w is a high-severity (CVSS 8.8) CWE-77 vulnerability in rlespinasse/github-slug-action. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for rlespinasse/github-slug-action — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-6q4m-7476-932w.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
rlespinasse/github-slug-actionReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects GitHub Actions packages — download data is not available via public APIs for these ecosystems.
Description
Impact
This action uses the github.head_ref parameter in an insecure way.
This vulnerability can be triggered by any user on GitHub on any workflow using the action on pull requests. They just need to create a pull request with a branch name, which can contain the attack payload. (Note that first-time PR requests will not be run - but the attacker can submit a valid PR before submitting an invalid PR). This can be used to execute code on the GitHub runners (potentially use it for crypto-mining, and waste your resources) and to exfiltrate any secrets you use in the CI pipeline.
Patches
Pass the variable as an environment variable and then use the environment variable instead of substituting it directly.
Patched action is available on tag v4, tag v4.4.1, and any tag beyond.
Workarounds
No workaround is available if impacted, please upgrade the version
ℹ️ v3 and v4 are compatibles.
References
Here is a set of blog posts by Github's security team explaining this issue.
Thanks
Thanks to the team of researchers from Purdue University, who are working on finding vulnerabilities in CI/CD configurations of open-source software. Their tool detected this security vulnerability.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦GitHub Actions | rlespinasse/github-slug-action | ≥ 4.0.0&&< 4.4.1 | 4.4.1 |
Affected Products
github-slug-actiongithub-slug-action_projectResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for rlespinasse/github-slug-action, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update rlespinasse/github-slug-action to 4.4.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-6q4m-7476-932w is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Frequently Asked Questions
Is GHSA-6q4m-7476-932w in your dependencies?
Find it across GitHub Actions, including transitive dependencies.