apko affected by unbounded resource consumption in expandapk.Split on attacker-controlled .apk streamsGHSA-6p9p-q6wh-9j89
MEDIUMFix: chainguard-dev/apko@2be3903GHSA-6p9p-q6wh-9j89 is a medium-severity (CVSS 5.5) Uncontrolled Resource Consumption vulnerability in chainguard.dev/apko. A fix is available for chainguard.dev/apko — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-6p9p-q6wh-9j89.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
chainguard.dev/apkoReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
expandapk.Split drains the first gzip stream of an APK archive via io.Copy(io.Discard, gzi) without explicit bounds. With an attacker-controlled input stream, this can force large gzip inflation work and lead to resource exhaustion (availability impact).
The Split function reads the first tar header, then drains the remainder of the gzip stream by reading from the gzip reader directly without any maximum uncompressed byte limit or inflate-ratio cap. A caller that parses attacker-controlled APK streams may be forced to spend excessive CPU time inflating gzip data, leading to timeouts or process slowdown.
Fix: Fixed with 2be3903, Released in v1.1.0.
Acknowledgements
apko thanks Oleh Konko from 1seal for discovering and reporting this issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | chainguard.dev/apko | ≥ 0.14.8&&< 1.1.0 | 1.1.0go get chainguard.dev/apko@v1.1.0 |
Affected Products
apkochainguardDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for chainguard.dev/apko, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update chainguard.dev/apko to 1.1.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-6p9p-q6wh-9j89 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is GHSA-6p9p-q6wh-9j89 in your dependencies?
Find it across Go, including transitive dependencies.